Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-0861

Overview

Vulnerability Score 6.8 6.8
CVE Id CVE-2012-0861
Last Modified 07 Jan 2013 10:03:02
Published 04 Jan 2013 05:55:01
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector ADJACENT_NETWORK
Access Complexity HIGH
Authentication NONE

CVE-2012-0861

Summary

The vds_installer in Red Hat Enterprise Virtualization Manager (RHEV-M) before 3.1, when adding a host, uses the -k curl parameter when downloading deployUtil.py and vds_bootstrap.py, which prevents SSL certificates from being validated and allows remote attackers to execute arbitrary Python code via a man-in-the-middle attack.

Vulnerable Systems

Application

  • Redhat Enterprise Virtualization Manager 2.1

  • Redhat Enterprise Virtualization Manager 2.2

  • Redhat Enterprise Virtualization Manager 2.2.3

  • Redhat Enterprise Virtualization Manager 3.0


References

XF - enterprise-ssl-certificates-mitm(80544)

SECTRACK - 1027838

BID - 56825

REDHAT - RHSA-2012:1508

REDHAT - RHSA-2012:1506

REDHAT - RHSA-2012:1505


Last Updated: 27 May 2016 10:57:37