Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-6531

Overview

Vulnerability Score 6.4 6.4
CVE Id CVE-2012-6531
Last Modified 04 Mar 2013 12:00:00
Published 13 Feb 2013 12:55:01
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2012-6531

Summary

(1) Zend_Dom, (2) Zend_Feed, and (3) Zend_Soap in Zend Framework 1.x before 1.11.13 and 1.12.x before 1.12.0 do not properly handle SimpleXMLElement classes, which allow remote attackers to read arbitrary files or create TCP connections via an external entity reference in a DOCTYPE element in an XML-RPC request, aka an XML external entity (XXE) injection attack, a different vulnerability than CVE-2012-3363.

Vulnerable Systems

Application

  • Zend Framework 1.0.4

  • Zend Framework 1.10.0

  • Zend Framework 1.10.1

  • Zend Framework 1.10.2

  • Zend Framework 1.10.3

  • Zend Framework 1.10.4

  • Zend Framework 1.10.5

  • Zend Framework 1.10.6

  • Zend Framework 1.10.7

  • Zend Framework 1.10.8

  • Zend Framework 1.11.0

  • Zend Framework 1.11.1

  • Zend Framework 1.11.10

  • Zend Framework 1.11.11

  • Zend Framework 1.11.12

  • Zend Framework 1.11.2

  • Zend Framework 1.11.3

  • Zend Framework 1.11.4

  • Zend Framework 1.11.5

  • Zend Framework 1.11.6

  • Zend Framework 1.11.7

  • Zend Framework 1.11.8

  • Zend Framework 1.11.9

  • Zend Framework 1.12.0

  • Zend Framework 1.5.0

  • Zend Framework 1.5.1

  • Zend Framework 1.5.2

  • Zend Framework 1.5.3

  • Zend Framework 1.6.0

  • Zend Framework 1.6.1

  • Zend Framework 1.6.2

  • Zend Framework 1.7.0

  • Zend Framework 1.7.1

  • Zend Framework 1.7.2

  • Zend Framework 1.7.3

  • Zend Framework 1.7.4

  • Zend Framework 1.7.5

  • Zend Framework 1.7.6

  • Zend Framework 1.7.7

  • Zend Framework 1.7.8

  • Zend Framework 1.7.9

  • Zend Framework 1.8.0

  • Zend Framework 1.8.1

  • Zend Framework 1.8.2

  • Zend Framework 1.8.3

  • Zend Framework 1.8.4

  • Zend Framework 1.8.5

  • Zend Framework 1.9.0

  • Zend Framework 1.9.1

  • Zend Framework 1.9.2

  • Zend Framework 1.9.3

  • Zend Framework 1.9.4

  • Zend Framework 1.9.5

  • Zend Framework 1.9.6

  • Zend Framework 1.9.7

  • Zend Framework 1.9.8


References

MISC - https://www.sec-consult.com/files/20120626-0_zend_framework_xxe_injection.txt

MLIST - [oss-security] 20120627 Re: XXE in Zend

MLIST - [oss-security] 20120626 Re: XXE in Zend

MLIST - [oss-security] 20120626 XXE in Zend

DEBIAN - DSA-2505

CONFIRM - http://framework.zend.com/security/advisory/ZF2012-01


Last Updated: 27 May 2016 11:01:52