Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2013-0238

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2013-0238
Last Modified 06 Feb 2014 11:44:38
Published 12 Feb 2013 08:55:04
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2013-0238

Summary

The try_parse_v4_netmask function in hostmask.c in IRCD-Hybrid before 8.0.6 does not properly validate masks, which allows remote attackers to cause a denial of service (crash) via a mask that causes a negative number to be parsed.

Vulnerable Systems

Application

  • Ircd-hybrid 7.2.0

  • Ircd-hybrid 7.2.1

  • Ircd-hybrid 7.2.2

  • Ircd-hybrid 7.2.3

  • Ircd-hybrid 7.3.0

  • Ircd-hybrid 7.3.1

  • Ircd-hybrid 8.0.0

  • Ircd-hybrid 8.0.1

  • Ircd-hybrid 8.0.2

  • Ircd-hybrid 8.0.3

  • Ircd-hybrid 8.0.4

  • Ircd-hybrid 8.0.5


References

XF - ircdhybrid-tryparsev4netmask-dos(81695)

BID - 57610

MLIST - [oss-security] 20130129 ircd-hybrid: Denial of service vulnerability in hostmask.c:try_parse_v4_netmask()

DEBIAN - DSA-2618

CONFIRM - http://svn.ircd-hybrid.org:8000/viewcvs.cgi/ircd-hybrid/trunk/src/hostmask.c?r1=1786&r2=1785&pathrev=1786

SECUNIA - 52106

SECUNIA - 51948

OSVDB - 89623

CONFIRM - http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=699267

EXPLOIT-DB - 24951

CONFIRM - https://wiki.mageia.org/en/Support/Advisories/MGASA-2013-0055

MANDRIVA - MDVSA-2013:093


Last Updated: 27 May 2016 11:01:50