Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2010-1445

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2010-1445
Last Modified 29 Dec 2014 04:02:55
Published 26 Dec 2014 03:59:06
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2010-1445

Summary

Heap-based buffer overflow in VideoLAN VLC media player before 1.0.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted byte stream in an RTMP session.

Vulnerable Systems

Application

  • Videolan Vlc Media Player 0.5.0

  • Videolan Vlc Media Player 0.5.1

  • Videolan Vlc Media Player 0.5.2

  • Videolan Vlc Media Player 0.5.3

  • Videolan Vlc Media Player 0.6.0

  • Videolan Vlc Media Player 0.6.1

  • Videolan Vlc Media Player 0.6.2

  • Videolan Vlc Media Player 0.7.0

  • Videolan Vlc Media Player 0.7.1

  • Videolan Vlc Media Player 0.7.2

  • Videolan Vlc Media Player 0.8.0

  • Videolan Vlc Media Player 0.8.1

  • Videolan Vlc Media Player 0.8.1337

  • Videolan Vlc Media Player 0.8.2

  • Videolan Vlc Media Player 0.8.4

  • Videolan Vlc Media Player 0.8.4a

  • Videolan Vlc Media Player 0.8.5

  • Videolan Vlc Media Player 0.8.6

  • Videolan Vlc Media Player 0.8.6a

  • Videolan Vlc Media Player 0.8.6b

  • Videolan Vlc Media Player 0.8.6c

  • Videolan Vlc Media Player 0.8.6d

  • Videolan Vlc Media Player 0.8.6e

  • Videolan Vlc Media Player 0.8.6f

  • Videolan Vlc Media Player 0.8.6g

  • Videolan Vlc Media Player 0.8.6h

  • Videolan Vlc Media Player 0.8.6i

  • Videolan Vlc Media Player 0.9.0

  • Videolan Vlc Media Player 0.9.1

  • Videolan Vlc Media Player 0.9.10

  • Videolan Vlc Media Player 0.9.2

  • Videolan Vlc Media Player 0.9.3

  • Videolan Vlc Media Player 0.9.4

  • Videolan Vlc Media Player 0.9.5

  • Videolan Vlc Media Player 0.9.6

  • Videolan Vlc Media Player 0.9.8a

  • Videolan Vlc Media Player 0.9.9

  • Videolan Vlc Media Player 0.9.9a

  • Videolan Vlc Media Player 1.0.0

  • Videolan Vlc Media Player 1.0.1

  • Videolan Vlc Media Player 1.0.2

  • Videolan Vlc Media Player 1.0.3

  • Videolan Vlc Media Player 1.0.4

  • Videolan Vlc Media Player 1.0.5


References

CONFIRM - http://www.videolan.org/security/sa1003.html

MLIST - [oss-security] 20100428 Re: CVE request: VLC <1.0.6 Multiple issues


Last Updated: 27 May 2016 11:07:22