Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-3623

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2011-3623
Last Modified 29 Dec 2014 05:53:07
Published 26 Dec 2014 03:59:08
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2011-3623

Summary

Multiple stack-based buffer overflows in VideoLAN VLC media player before 1.0.2 allow remote attackers to execute arbitrary code via (1) a crafted ASF file, related to the ASF_ObjectDumpDebug function in modules/demux/asf/libasf.c; (2) a crafted AVI file, related to the AVI_ChunkDumpDebug_level function in modules/demux/avi/libavi.c; or (3) a crafted MP4 file, related to the __MP4_BoxDumpStructure function in modules/demux/mp4/libmp4.c.

Vulnerable Systems

Application

  • Videolan Vlc Media Player 0.5.0

  • Videolan Vlc Media Player 0.5.1

  • Videolan Vlc Media Player 0.5.2

  • Videolan Vlc Media Player 0.5.3

  • Videolan Vlc Media Player 0.6.0

  • Videolan Vlc Media Player 0.6.1

  • Videolan Vlc Media Player 0.6.2

  • Videolan Vlc Media Player 0.7.0

  • Videolan Vlc Media Player 0.7.1

  • Videolan Vlc Media Player 0.7.2

  • Videolan Vlc Media Player 0.8.0

  • Videolan Vlc Media Player 0.8.1

  • Videolan Vlc Media Player 0.8.1337

  • Videolan Vlc Media Player 0.8.2

  • Videolan Vlc Media Player 0.8.4

  • Videolan Vlc Media Player 0.8.4a

  • Videolan Vlc Media Player 0.8.5

  • Videolan Vlc Media Player 0.8.6

  • Videolan Vlc Media Player 0.8.6a

  • Videolan Vlc Media Player 0.8.6b

  • Videolan Vlc Media Player 0.8.6c

  • Videolan Vlc Media Player 0.8.6d

  • Videolan Vlc Media Player 0.8.6e

  • Videolan Vlc Media Player 0.8.6f

  • Videolan Vlc Media Player 0.8.6g

  • Videolan Vlc Media Player 0.8.6h

  • Videolan Vlc Media Player 0.8.6i

  • Videolan Vlc Media Player 0.9.0

  • Videolan Vlc Media Player 0.9.1

  • Videolan Vlc Media Player 0.9.10

  • Videolan Vlc Media Player 0.9.2

  • Videolan Vlc Media Player 0.9.3

  • Videolan Vlc Media Player 0.9.4

  • Videolan Vlc Media Player 0.9.5

  • Videolan Vlc Media Player 0.9.6

  • Videolan Vlc Media Player 0.9.8a

  • Videolan Vlc Media Player 0.9.9

  • Videolan Vlc Media Player 0.9.9a

  • Videolan Vlc Media Player 1.0.0

  • Videolan Vlc Media Player 1.0.1


References

CONFIRM - https://bugs.gentoo.org/show_bug.cgi?id=285370

CONFIRM - http://www.videolan.org/security/sa0901.html

MLIST - [oss-security] 20111018 Re: CVE requests:

CONFIRM - http://git.videolan.org/?p=vlc.git;a=commit;h=dfe7084e8cc64e9b7a87cd37065b59cba2064823

CONFIRM - http://git.videolan.org/?p=vlc.git;a=commit;h=c5b02d011b8c634d041167f4d2936b55eca4d18d

CONFIRM - http://git.videolan.org/?p=vlc.git;a=commit;h=861e374d03e6c60c7d3c98428c632fe3b9e371b2


Last Updated: 27 May 2016 11:07:22