Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-6637

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2012-6637
Last Modified 03 Mar 2014 03:42:03
Published 02 Mar 2014 11:50:46
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2012-6637

Summary

Apache Cordova 3.3.0 and earlier and Adobe PhoneGap 2.9.0 and earlier do not anchor the end of domain-name regular expressions, which allows remote attackers to bypass a whitelist protection mechanism via a domain name that contains an acceptable name as an initial substring.

Vulnerable Systems

Application

  • Adobe Phonegap 2.0.0

  • Adobe Phonegap 2.1.0

  • Adobe Phonegap 2.2.0

  • Adobe Phonegap 2.3.0

  • Adobe Phonegap 2.4.0

  • Adobe Phonegap 2.5.0

  • Adobe Phonegap 2.6.0

  • Adobe Phonegap 2.7.0

  • Adobe Phonegap 2.8.0

  • Adobe Phonegap 2.8.1

  • Adobe Phonegap 2.9.0

  • Apache Cordova 3.0.0

  • Apache Cordova 3.1.0

  • Apache Cordova 3.2.0

  • Apache Cordova 3.3.0


References

BUGTRAQ - 20140124 Security Vulnerabilities in Apache Cordova / PhoneGap

MISC - http://www.internetsociety.org/ndss2014/programme#session3

MISC - http://www.cs.utexas.edu/~shmat/shmat_ndss14nofrak.pdf

MISC - http://packetstormsecurity.com/files/124954/apachecordovaphonegap-bypass.txt

MLIST - [oss-security] 20140207 Re: CVE request: multiple issues in Apache Cordova/PhoneGap

MISC - http://labs.mwrinfosecurity.com/blog/2012/04/30/building-android-javajavascript-bridges/


Last Updated: 27 May 2016 10:56:46