Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2013-4570

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2013-4570
Last Modified 12 May 2014 12:13:43
Published 12 May 2014 10:55:04
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2013-4570

Summary

The zend_inline_hash_func function in php-luasandbox in the Scribuntu extension for MediaWiki before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via vectors related to converting Lua data structures to PHP, as demonstrated by passing { [{}] = 1 } to a module function.

Vulnerable Systems

Application

  • Mediawiki 1.19

  • Mediawiki 1.19.0

  • Mediawiki 1.19.1

  • Mediawiki 1.19.2

  • Mediawiki 1.19.3

  • Mediawiki 1.19.4

  • Mediawiki 1.19.5

  • Mediawiki 1.19.6

  • Mediawiki 1.19.7

  • Mediawiki 1.19.8

  • Mediawiki 1.19.9

  • Mediawiki 1.21

  • Mediawiki 1.21.1

  • Mediawiki 1.21.2

  • Mediawiki 1.21.3

  • Mediawiki 1.22.0


References

CONFIRM - https://bugzilla.wikimedia.org/show_bug.cgi?id=54527

MLIST - [MediaWiki-announce] 20140114 MediaWiki Security Releases: 1.22.1, 1.21.4 and 1.19.10


Last Updated: 27 May 2016 11:05:13