Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2013-6396

Overview

Vulnerability Score 5.8 5.8
CVE Id CVE-2013-6396
Last Modified 20 Feb 2014 07:40:56
Published 18 Feb 2014 02:55:04
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2013-6396

Summary

The OpenStack Python client library for Swift (python-swiftclient) 1.0 through 1.9.0 does not verify X.509 certificates from SSL servers, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information via a crafted certificate.

Vulnerable Systems

Application

  • Openstack Swift 1.0.0

  • Openstack Swift 1.0.1

  • Openstack Swift 1.0.2

  • Openstack Swift 1.1.0

  • Openstack Swift 1.10.0

  • Openstack Swift 1.11.0

  • Openstack Swift 1.2.0

  • Openstack Swift 1.3.0

  • Openstack Swift 1.4.0

  • Openstack Swift 1.4.1

  • Openstack Swift 1.4.2

  • Openstack Swift 1.4.3

  • Openstack Swift 1.4.4

  • Openstack Swift 1.4.5

  • Openstack Swift 1.4.6

  • Openstack Swift 1.4.7

  • Openstack Swift 1.4.8

  • Openstack Swift 1.5.0

  • Openstack Swift 1.6.0

  • Openstack Swift 1.7.0

  • Openstack Swift 1.7.2

  • Openstack Swift 1.7.4

  • Openstack Swift 1.7.5

  • Openstack Swift 1.7.6

  • Openstack Swift 1.8.0

  • Openstack Swift 1.9.0


References

CONFIRM - https://bugs.launchpad.net/python-swiftclient/+bug/1199783

MLIST - [oss-security] 20140217 [OSSA 2014-005] Missing SSL certificate check in Python Swift client (CVE-2013-6396)


Last Updated: 27 May 2016 11:04:28