Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-0060

Overview

Vulnerability Score 4.0 4.0
CVE Id CVE-2014-0060
Last Modified 24 Oct 2014 03:05:46
Published 31 Mar 2014 10:58:08
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication SINGLE_INSTANCE

CVE-2014-0060

Summary

PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 does not properly enforce the ADMIN OPTION restriction, which allows remote authenticated members of a role to add or remove arbitrary users to that role by calling the SET ROLE command before the associated GRANT command.

Vulnerable Systems

Application

  • Postgresql 8.4.1

  • Postgresql 8.4.10

  • Postgresql 8.4.11

  • Postgresql 8.4.12

  • Postgresql 8.4.13

  • Postgresql 8.4.14

  • Postgresql 8.4.15

  • Postgresql 8.4.16

  • Postgresql 8.4.17

  • Postgresql 8.4.18

  • Postgresql 8.4.19

  • Postgresql 8.4.2

  • Postgresql 8.4.3

  • Postgresql 8.4.4

  • Postgresql 8.4.5

  • Postgresql 8.4.6

  • Postgresql 8.4.7

  • Postgresql 8.4.8

  • Postgresql 8.4.9

  • Postgresql 9.0

  • Postgresql 9.0.1

  • Postgresql 9.0.10

  • Postgresql 9.0.11

  • Postgresql 9.0.12

  • Postgresql 9.0.13

  • Postgresql 9.0.14

  • Postgresql 9.0.15

  • Postgresql 9.0.2

  • Postgresql 9.0.3

  • Postgresql 9.0.4

  • Postgresql 9.0.5

  • Postgresql 9.0.6

  • Postgresql 9.0.7

  • Postgresql 9.0.8

  • Postgresql 9.0.9

  • Postgresql 9.1

  • Postgresql 9.1.1

  • Postgresql 9.1.10

  • Postgresql 9.1.11

  • Postgresql 9.1.2

  • Postgresql 9.1.3

  • Postgresql 9.1.4

  • Postgresql 9.1.5

  • Postgresql 9.1.6

  • Postgresql 9.1.7

  • Postgresql 9.1.8

  • Postgresql 9.1.9

  • Postgresql 9.2

  • Postgresql 9.2.1

  • Postgresql 9.2.2

  • Postgresql 9.2.3

  • Postgresql 9.2.4

  • Postgresql 9.2.5

  • Postgresql 9.2.6

  • Postgresql 9.3

  • Postgresql 9.3.1

  • Postgresql 9.3.2


References

CONFIRM - http://www.postgresql.org/about/news/1506/

DEBIAN - DSA-2865

DEBIAN - DSA-2864

CONFIRM - http://wiki.postgresql.org/wiki/20140220securityrelease

REDHAT - RHSA-2014:0469

CONFIRM - http://support.apple.com/kb/HT6448

CONFIRM - https://support.apple.com/kb/HT6536

APPLE - APPLE-SA-2014-10-16-3


Last Updated: 27 May 2016 11:06:50