Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-0474

Overview

Vulnerability Score 10.0 10.0
CVE Id CVE-2014-0474
Last Modified 13 Nov 2014 10:01:23
Published 23 Apr 2014 11:55:03
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2014-0474

Summary

The (1) FilePathField, (2) GenericIPAddressField, and (3) IPAddressField model field classes in Django before 1.4.11, 1.5.x before 1.5.6, 1.6.x before 1.6.3, and 1.7.x before 1.7 beta 2 do not properly perform type conversion, which allows remote attackers to have unspecified impact and vectors, related to "MySQL typecasting."

Vulnerable Systems

Operating System

  • Canonical Ubuntu Linux 10.04

  • Canonical Ubuntu Linux 12.04

  • Canonical Ubuntu Linux 12.10

  • Canonical Ubuntu Linux 13.10

  • Canonical Ubuntu Linux 14.04

Application

  • Djangoproject Django 1.4

  • Djangoproject Django 1.4.1

  • Djangoproject Django 1.4.10

  • Djangoproject Django 1.4.2

  • Djangoproject Django 1.4.3

  • Djangoproject Django 1.4.4

  • Djangoproject Django 1.4.5

  • Djangoproject Django 1.4.6

  • Djangoproject Django 1.4.7

  • Djangoproject Django 1.4.8

  • Djangoproject Django 1.4.9

  • Djangoproject Django 1.5

  • Djangoproject Django 1.5.1

  • Djangoproject Django 1.5.2

  • Djangoproject Django 1.5.3

  • Djangoproject Django 1.5.4

  • Djangoproject Django 1.5.5

  • Djangoproject Django 1.6

  • Djangoproject Django 1.6.1

  • Djangoproject Django 1.6.2

  • Djangoproject Django 1.7


References

CONFIRM - https://www.djangoproject.com/weblog/2014/apr/21/security/

UBUNTU - USN-2169-1

DEBIAN - DSA-2934

REDHAT - RHSA-2014:0457

REDHAT - RHSA-2014:0456

SUSE - openSUSE-SU-2014:1132


Last Updated: 27 May 2016 11:08:12