Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-1418

Overview

Vulnerability Score 6.4 6.4
CVE Id CVE-2014-1418
Last Modified 13 Nov 2014 10:02:24
Published 16 May 2014 11:55:04
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2014-1418

Summary

Django 1.4 before 1.4.13, 1.5 before 1.5.8, 1.6 before 1.6.5, and 1.7 before 1.7b4 does not properly include the (1) Vary: Cookie or (2) Cache-Control header in responses, which allows remote attackers to obtain sensitive information or poison the cache via a request from certain browsers.

Vulnerable Systems

Operating System

  • Canonical Ubuntu Linux 10.04

  • Canonical Ubuntu Linux 12.04

  • Canonical Ubuntu Linux 12.10

  • Canonical Ubuntu Linux 13.10

  • Canonical Ubuntu Linux 14.04

Application

  • Djangoproject Django 1.4

  • Djangoproject Django 1.4.1

  • Djangoproject Django 1.4.10

  • Djangoproject Django 1.4.11

  • Djangoproject Django 1.4.12

  • Djangoproject Django 1.4.2

  • Djangoproject Django 1.4.4

  • Djangoproject Django 1.4.5

  • Djangoproject Django 1.4.6

  • Djangoproject Django 1.4.7

  • Djangoproject Django 1.4.8

  • Djangoproject Django 1.4.9

  • Djangoproject Django 1.5

  • Djangoproject Django 1.5.1

  • Djangoproject Django 1.5.2

  • Djangoproject Django 1.5.3

  • Djangoproject Django 1.5.4

  • Djangoproject Django 1.5.5

  • Djangoproject Django 1.5.6

  • Djangoproject Django 1.5.7

  • Djangoproject Django 1.6

  • Djangoproject Django 1.6.1

  • Djangoproject Django 1.6.2

  • Djangoproject Django 1.6.3

  • Djangoproject Django 1.6.4

  • Djangoproject Django 1.7


References

CONFIRM - https://www.djangoproject.com/weblog/2014/may/14/security-releases-issued/

MLIST - [oss-security] 20140514 Re: CVE Reuest: Django: Malformed URLs from user input incorrectly validated

MLIST - [oss-security] 20140514 CVE Reuest: Django: Malformed URLs from user input incorrectly validated

UBUNTU - USN-2212-1

DEBIAN - DSA-2934

SUSE - openSUSE-SU-2014:1132


Last Updated: 27 May 2016 11:05:18