Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-1882

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2014-1882
Last Modified 03 Mar 2014 03:26:49
Published 02 Mar 2014 11:50:46
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2014-1882

Summary

Apache Cordova 3.3.0 and earlier and Adobe PhoneGap 2.9.0 and earlier allow remote attackers to bypass intended device-resource restrictions of an event-based bridge via a crafted library clone that leverages IFRAME script execution and directly accesses bridge JavaScript objects, as demonstrated by certain cordova.require calls.

Vulnerable Systems

Application

  • Adobe Phonegap 2.0.0

  • Adobe Phonegap 2.1.0

  • Adobe Phonegap 2.2.0

  • Adobe Phonegap 2.3.0

  • Adobe Phonegap 2.4.0

  • Adobe Phonegap 2.5.0

  • Adobe Phonegap 2.6.0

  • Adobe Phonegap 2.7.0

  • Adobe Phonegap 2.8.0

  • Adobe Phonegap 2.8.1

  • Adobe Phonegap 2.9.0

  • Apache Cordova 3.0.0

  • Apache Cordova 3.1.0

  • Apache Cordova 3.2.0

  • Apache Cordova 3.3.0


References

MISC - http://www.internetsociety.org/ndss2014/programme#session3

MISC - http://www.cs.utexas.edu/~shmat/shmat_ndss14nofrak.pdf

BUGTRAQ - 20140124 Security Vulnerabilities in Apache Cordova / PhoneGap

MISC - http://packetstormsecurity.com/files/124954/apachecordovaphonegap-bypass.txt

MLIST - [oss-security] 20140207 Re: CVE request: multiple issues in Apache Cordova/PhoneGap


Last Updated: 27 May 2016 11:04:31