Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-1883

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2014-1883
Last Modified 03 Mar 2014 03:32:03
Published 02 Mar 2014 11:50:46
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2014-1883

Summary

Adobe PhoneGap before 2.6.0 on Android uses the shouldOverrideUrlLoading callback instead of the proper shouldInterceptRequest callback, which allows remote attackers to bypass intended device-resource restrictions via content that is accessed (1) in an IFRAME element or (2) with the XMLHttpRequest method by a crafted application.

Vulnerable Systems

Application

  • Adobe Phonegap 2.0.0

  • Adobe Phonegap 2.1.0

  • Adobe Phonegap 2.2.0

  • Adobe Phonegap 2.3.0

  • Adobe Phonegap 2.4.0

  • Adobe Phonegap 2.5.0


References

MISC - https://github.com/phonegap/phonegap/blob/2.6.0/changelog

MISC - http://www.internetsociety.org/ndss2014/programme#session3

MISC - http://www.cs.utexas.edu/~shmat/shmat_ndss14nofrak.pdf

BUGTRAQ - 20140124 Security Vulnerabilities in Apache Cordova / PhoneGap

MISC - http://packetstormsecurity.com/files/124954/apachecordovaphonegap-bypass.txt

MLIST - [oss-security] 20140207 Re: CVE request: multiple issues in Apache Cordova/PhoneGap


Last Updated: 27 May 2016 11:04:31