Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-2538

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2014-2538
Last Modified 08 Oct 2015 10:44:58
Published 25 Mar 2014 02:21:48
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2014-2538

Summary

Cross-site scripting (XSS) vulnerability in lib/rack/ssl.rb in the rack-ssl gem before 1.4.0 for Ruby allows remote attackers to inject arbitrary web script or HTML via a URI, which might not be properly handled by third-party adapters such as JRuby-Rack.

Vulnerable Systems

Application

  • Joshua Peek Rack-ssl 1.0.0

  • Joshua Peek Rack-ssl 1.1.0

  • Joshua Peek Rack-ssl 1.2.0

  • Joshua Peek Rack-ssl 1.3.0

  • Joshua Peek Rack-ssl 1.3.1

  • Joshua Peek Rack-ssl 1.3.2

  • Joshua Peek Rack-ssl 1.3.3

  • Joshua Peek Rack-ssl 1.3.4


References

CONFIRM - https://github.com/josh/rack-ssl/commit/9d7d7300b907e496db68d89d07fbc2e0df0b487b

MLIST - [oss-security] 20140319 Re: CVE Request: rack-ssl rubygem: XSS in error page

SECUNIA - 57466

SUSE - openSUSE-SU-2014:0515

BID - 66314


Last Updated: 27 May 2016 11:04:47