Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-2572

Overview

Vulnerability Score 4.0 4.0
CVE Id CVE-2014-2572
Last Modified 24 Mar 2014 06:29:58
Published 24 Mar 2014 10:20:39
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication SINGLE_INSTANCE

CVE-2014-2572

Summary

mod/assign/externallib.php in Moodle 2.6.x before 2.6.2 does not properly handle assignment web-service parameters, which might allow remote authenticated users to modify grade metadata via unspecified vectors.

Vulnerable Systems

Application

  • Moodle 2.6

  • Moodle 2.6.1


References

CONFIRM - https://moodle.org/mod/forum/discuss.php?d=256425

MLIST - [oss-security] 20140317 Moodle security notifications public

CONFIRM - http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-43468


Last Updated: 27 May 2016 11:04:46