Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-2922

Overview

Vulnerability Score 6.4 6.4
CVE Id CVE-2014-2922
Last Modified 22 Apr 2014 11:06:56
Published 21 Apr 2014 06:55:08
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2014-2922

Summary

The getObjectByToken function in Newsletter.php in the Pimcore_Tool_Newsletter module in pimcore 1.4.9 through 2.1.0 does not properly handle an object obtained by unserializing a pathname, which allows remote attackers to conduct PHP object injection attacks and delete arbitrary files via vectors involving a Zend_Http_Response_Stream object.

Vulnerable Systems

Application

  • Pimcore 1.4.9

  • Pimcore 1.5.0

  • Pimcore 2.1.0


References

MISC - https://github.com/pedrib/PoC/blob/master/pimcore-2.1.0.txt

CONFIRM - http://www.pimcore.org/en/resources/blog/pimcore+2.2+released_b442

MLIST - [oss-security] 20140421 Re: Remote code execution in Pimcore CMS


Last Updated: 27 May 2016 11:05:03