Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-3971

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2014-3971
Last Modified 29 Dec 2014 11:47:41
Published 25 Dec 2014 06:59:00
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2014-3971

Summary

The CmdAuthenticate::_authenticateX509 function in db/commands/authentication_commands.cpp in mongod in MongoDB 2.6.x before 2.6.2 allows remote attackers to cause a denial of service (daemon crash) by attempting authentication with an invalid X.509 client certificate.

Vulnerable Systems

Application

  • Mongodb 2.6.0

  • Mongodb 2.6.1


References

CONFIRM - https://jira.mongodb.org/browse/SERVER-13753

CONFIRM - https://github.com/mongodb/mongo/commit/c151e0660b9736fe66b224f1129a16871165251b


Last Updated: 27 May 2016 11:07:22