Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-7193

Overview

Vulnerability Score 5.8 5.8
CVE Id CVE-2014-7193
Last Modified 29 Dec 2014 06:09:28
Published 25 Dec 2014 06:59:01
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2014-7193

Summary

The Crumb plugin before 3.0.0 for Node.js does not properly restrict token access in situations where a hapi route handler has CORS enabled, which allows remote attackers to obtain sensitive information, and potentially obtain the ability to spoof requests to non-CORS routes, via a crafted web site that is visited by an application consumer.

Vulnerable Systems

Application

  • Hapijs Crumb 2.2.0


References

CONFIRM - https://nodesecurity.io/advisories/crumb_cors_token_disclosure

CONFIRM - https://github.com/hapijs/crumb/commit/5e6d4f5c81677fe9e362837ffd4a02394303db3c


Last Updated: 27 May 2016 11:07:22