Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-8109

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2014-8109
Last Modified 18 Sep 2015 09:59:32
Published 29 Dec 2014 06:59:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2014-8109

Summary

mod_lua.c in the mod_lua module in the Apache HTTP Server 2.3.x and 2.4.x through 2.4.10 does not support an httpd configuration in which the same Lua authorization provider is used with different arguments within different contexts, which allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging multiple Require directives, as demonstrated by a configuration that specifies authorization for one group to access a certain directory, and authorization for a second group to access a second directory.

Vulnerable Systems

Operating System

  • Canonical Ubuntu Linux 10.04

  • Canonical Ubuntu Linux 12.04

  • Canonical Ubuntu Linux 14.04

  • Canonical Ubuntu Linux 14.10

Application

  • Apache Http Server 2.3.0

  • Apache Http Server 2.3.1

  • Apache Http Server 2.3.10

  • Apache Http Server 2.3.11

  • Apache Http Server 2.3.12

  • Apache Http Server 2.3.13

  • Apache Http Server 2.3.14

  • Apache Http Server 2.3.15

  • Apache Http Server 2.3.16

  • Apache Http Server 2.3.2

  • Apache Http Server 2.3.3

  • Apache Http Server 2.3.4

  • Apache Http Server 2.3.5

  • Apache Http Server 2.3.6

  • Apache Http Server 2.3.7

  • Apache Http Server 2.3.8

  • Apache Http Server 2.3.9

  • Apache Http Server 2.4.0

  • Apache Http Server 2.4.1

  • Apache Http Server 2.4.10

  • Apache Http Server 2.4.2

  • Apache Http Server 2.4.3

  • Apache Http Server 2.4.6

  • Apache Http Server 2.4.7

  • Apache Http Server 2.4.8

  • Apache Http Server 2.4.9


References

CONFIRM - https://issues.apache.org/bugzilla/show_bug.cgi?id=57204

CONFIRM - https://github.com/apache/httpd/commit/3f1693d558d0758f829c8b53993f1749ddf6ffcb

CONFIRM - https://bugzilla.redhat.com/show_bug.cgi?id=1174077

MLIST - [oss-security] 20141128 CVE Request: "LuaAuthzProvider" in Apache HTTP Server mixes up arguments

UBUNTU - USN-2523-1

CONFIRM - http://advisories.mageia.org/MGASA-2015-0011.html

CONFIRM - https://support.apple.com/kb/HT205031

APPLE - APPLE-SA-2015-08-13-2

CONFIRM - https://support.apple.com/HT205219

APPLE - APPLE-SA-2015-09-16-4


Last Updated: 27 May 2016 11:08:07