Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-8116

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2014-8116
Last Modified 14 Apr 2015 10:01:55
Published 17 Dec 2014 02:59:02
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2014-8116

Summary

The ELF parser (readelf.c) in file before 5.21 allows remote attackers to cause a denial of service (CPU consumption or crash) via a large number of (1) program or (2) section headers or (3) invalid capabilities.

Vulnerable Systems

Operating System

  • Freebsd

Application

  • File Project File 5.20


References

FREEBSD - FreeBSD-SA-14:28

CONFIRM - https://github.com/file/file/commit/d7cdad007c507e6c79f51f058dd77fab70ceb9f6

CONFIRM - https://github.com/file/file/commit/b4c01141e5367f247b84dcaf6aefbb4e741842b8

CONFIRM - https://github.com/file/file/blob/00cef282a902a4a6709bbbbb933ee397768caa38/ChangeLog

SECTRACK - 1031344

MLIST - [oss-security] 20141216 file(1): multiple denial of service issues (resource consumption), CVE-2014-8116 and CVE-2014-8117

UBUNTU - USN-2494-1

CONFIRM - http://advisories.mageia.org/MGASA-2015-0040.html


Last Updated: 27 May 2016 11:08:01