Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-9376

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2014-9376
Last Modified 12 Jan 2015 02:19:11
Published 19 Dec 2014 10:59:27
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2014-9376

Summary

Integer underflow in Ettercap 0.8.1 allows remote attackers to cause a denial of service (out-of-bounds write) and possibly execute arbitrary code via a small (1) size variable value in the dissector_dhcp function in dissectors/ec_dhcp.c, (2) length value to the dissector_gg function in dissectors/ec_gg.c, or (3) string length to the get_decode_len function in ec_utils.c or a request without a (4) username or (5) password to the dissector_TN3270 function in dissectors/ec_TN3270.c.

Vulnerable Systems

Application

  • Ettercap Project Ettercap 0.8.1


References

MISC - https://www.obrela.com/home/security-labs/advisories/osi-advisory-osi-1402/

CONFIRM - https://github.com/Ettercap/ettercap/pull/609

CONFIRM - https://github.com/Ettercap/ettercap/pull/606

CONFIRM - https://github.com/Ettercap/ettercap/pull/605

CONFIRM - https://github.com/Ettercap/ettercap/pull/602

BUGTRAQ - 20141216 "Ettercap 8.0 - 8.1" multiple vulnerabilities


Last Updated: 27 May 2016 11:07:20