Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-9414

Overview

Vulnerability Score 6.8 6.8
CVE Id CVE-2014-9414
Last Modified 12 Jan 2015 02:22:42
Published 24 Dec 2014 01:59:11
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2014-9414

Summary

The W3 Total Cache plugin before 0.9.4.1 for WordPress does not properly handle empty nonces, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks and hijack the authentication of administrators for requests that change the mobile site redirect URI via the mobile_groups[*][redirect] parameter and an empty _wpnonce parameter in the w3tc_mobile page to wp-admin/admin.php.

Vulnerable Systems

Application

  • W3edge Total Cache 0.9.4


References

CONFIRM - https://wordpress.org/plugins/w3-total-cache/changelog/

CONFIRM - https://github.com/wp-plugins/w3-total-cache/commit/9a1cc9f70558282e135eb3120d271448c75b28dd#diff-86a10b31ab115483fe8111bedac14d15

SECUNIA - 61562

FULLDISC - 20141216 W3TotalFail: W3 Total Cache v 0.9.4 CSRF Vulnerability that Leads to Full Deface

MISC - http://packetstormsecurity.com/files/129512/W3-Total-Cache-0.9.4-Cross-Site-Request-Forgery.html

MISC - http://mazinahmed1.blogspot.com/2014/12/w3-total-caches-w3totalfail.html

XF - w3totalcache-wordpress-wpnonce-csrf(99352)


Last Updated: 27 May 2016 11:07:22