Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-3691

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2014-3691
Last Modified 17 Mar 2015 10:01:28
Published 09 Mar 2015 10:59:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2014-3691

Summary

Smart Proxy (aka Smart-Proxy and foreman-proxy) in Foreman before 1.5.4 and 1.6.x before 1.6.2 does not validate SSL certificates, which allows remote attackers to bypass intended authentication and execute arbitrary API requests via a request without a certificate.

Vulnerable Systems

Application

  • Theforeman Foreman 1.5.3

  • Theforeman Foreman 1.6.0

  • Theforeman Foreman 1.6.1


References

CONFIRM - https://groups.google.com/forum/#!topic/foreman-announce/jXC5ixybjqo

CONFIRM - https://github.com/theforeman/smart-proxy/pull/217

REDHAT - RHSA-2015:0288

REDHAT - RHSA-2015:0287

CONFIRM - http://projects.theforeman.org/issues/7822


Last Updated: 27 May 2016 11:08:00