Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-7957

Overview

Vulnerability Score 6.8 6.8
CVE Id CVE-2014-7957
Last Modified 15 Jan 2015 07:31:12
Published 15 Jan 2015 10:59:04
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2014-7957

Summary

Multiple cross-site request forgery (CSRF) vulnerabilities in the Pods plugin before 2.5 for WordPress allow remote attackers to hijack the authentication of administrators for requests that (1) conduct cross-site scripting (XSS) attacks via the toggled parameter in a toggle action in the pods-components page to wp-admin/admin.php, (2) delete a pod in a delete action in the pods page to wp-admin/admin.php, (3) reset pod settings and data via the pods_reset parameter in the pod-settings page to wp-admin/admin.php, (4) deactivate and reset pod data via the pods_reset_deactivate parameter in the pod-settings page to wp-admin/admin.php, (5) delete the admin role via the id parameter in a delete action in the pods-component-roles-and-capabilities page to wp-admin/admin.php, or (6) enable "roles and capabilities" in a toggle action in the pods-components page to wp-admin/admin.php.

Vulnerable Systems

Application

  • Pods Foundation Pods 2.4.3


References

CONFIRM - https://wordpress.org/plugins/pods/changelog/

BID - 71996

BUGTRAQ - 20150110 Wordpress plugin Pods <= 2.4.3 XSS and CSRF vulnerabilities

FULLDISC - 20150112 Wordpress plugin Pods <= 2.4.3 XSS and CSRF vulnerabilities

MISC - http://packetstormsecurity.com/files/129890/WordPress-Pods-2.4.3-CSRF-Cross-Site-Scripting.html


Last Updated: 27 May 2016 11:07:33