Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2014-9709

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2014-9709
Last Modified 09 Oct 2015 10:00:07
Published 30 Mar 2015 06:59:05
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2014-9709

Summary

The GetCode_ function in gd_gif_in.c in GD 2.1.1 and earlier, as used in PHP before 5.5.21 and 5.6.x before 5.6.5, allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted GIF image that is improperly handled by the gdImageCreateFromGif function.

Vulnerable Systems

Operating System

  • Novell Opensuse 13.1

  • Novell Opensuse 13.2

Application

  • Libgd 2.1.1

  • Php 5.4.39

  • Php 5.5.20

  • Php 5.6.0

  • Php 5.6.1

  • Php 5.6.2

  • Php 5.6.3

  • Php 5.6.4


References

CONFIRM - https://bugzilla.redhat.com/show_bug.cgi?id=1188639

CONFIRM - https://bugs.php.net/bug.php?id=68601

CONFIRM - https://bitbucket.org/libgd/gd-libgd/commits/47eb44b2e90ca88a08dca9f9a1aa9041e9587f43

CONFIRM - http://php.net/ChangeLog-5.php

SUSE - openSUSE-SU-2015:0644

DEBIAN - DSA-3215

MANDRIVA - MDVSA-2015:153

CONFIRM - http://advisories.mageia.org/MGASA-2015-0040.html

CONFIRM - https://support.apple.com/HT205267

APPLE - APPLE-SA-2015-09-30-3


Last Updated: 27 May 2016 11:08:49