Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2015-0204

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2015-0204
Last Modified 16 Jul 2015 10:01:20
Published 08 Jan 2015 09:59:10
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2015-0204

Summary

The ssl3_get_key_exchange function in s3_clnt.c in OpenSSL before 0.9.8zd, 1.0.0 before 1.0.0p, and 1.0.1 before 1.0.1k allows remote SSL servers to conduct RSA-to-EXPORT_RSA downgrade attacks and facilitate brute-force decryption by offering a weak ephemeral RSA key in a noncompliant role, related to the "FREAK" issue. NOTE: the scope of this CVE is only client code based on OpenSSL, not EXPORT_RSA issues associated with servers or other TLS implementations.

Vulnerable Systems

Application

  • Openssl 0.9.8zc

  • Openssl 1.0.0a

  • Openssl 1.0.0b

  • Openssl 1.0.0c

  • Openssl 1.0.0d

  • Openssl 1.0.0e

  • Openssl 1.0.0f

  • Openssl 1.0.0g

  • Openssl 1.0.0h

  • Openssl 1.0.0i

  • Openssl 1.0.0j

  • Openssl 1.0.0k

  • Openssl 1.0.0l

  • Openssl 1.0.0m

  • Openssl 1.0.0n

  • Openssl 1.0.0o

  • Openssl 1.0.1a

  • Openssl 1.0.1b

  • Openssl 1.0.1c

  • Openssl 1.0.1d

  • Openssl 1.0.1e

  • Openssl 1.0.1f

  • Openssl 1.0.1g

  • Openssl 1.0.1h

  • Openssl 1.0.1i

  • Openssl 1.0.1j


References

CONFIRM - https://www.openssl.org/news/secadv_20150108.txt

CONFIRM - https://github.com/openssl/openssl/commit/ce325c60c74b0fa784f5872404b722e120e5cab0

MANDRIVA - MDVSA-2015:019

CONFIRM - http://support.novell.com/security/cve/CVE-2015-0204.html

MISC - https://freakattack.com/

DEBIAN - DSA-3125

HP - SSRT101885

SUSE - openSUSE-SU-2015:0130

CISCO - 20150310 Multiple Vulnerabilities in OpenSSL (January 2015) Affecting Cisco Products

REDHAT - RHSA-2015:0066

CONFIRM - https://www.openssl.org/news/secadv_20150319.txt

HP - HPSBHF03289

HP - SSRT101987

SUSE - SUSE-SU-2015:0578

MANDRIVA - MDVSA-2015:063

MANDRIVA - MDVSA-2015:062

CONFIRM - https://support.apple.com/HT204659

APPLE - APPLE-SA-2015-04-08-2

CONFIRM - http://www.oracle.com/technetwork/topics/security/cpuapr2015-2365600.html

REDHAT - RHSA-2015:0849

REDHAT - RHSA-2015:0800

SUSE - SUSE-SU-2015:0946

CONFIRM - http://www-01.ibm.com/support/docview.wss?uid=swg21883640

CONFIRM - http://www.oracle.com/technetwork/topics/security/cpujul2015-2367936.html

Related Patches

Apple 2015-004 Security Update for Mac OS X 10.8.5 (HT204659)

Apple 2015-004 Security Update for Mac OS X 10.9.5 (HT204659)

Apple Yosemite 10.10.3 Update (Combo) for Mac OS X (HT204659)

Apple Yosemite 10.10.3 Update for Mac OS X (HT204659)

Novell SUSE 2015:10761 java-1_6_0-ibm security update for SLES 11 SP3 i586

Novell SUSE 2015:10761 java-1_6_0-ibm security update for SLES 11 SP3 x86_64

Novell SUSE 2015:10784 java-1_7_0-ibm security update for SLES 11 SP3 i586

Novell SUSE 2015:10784 java-1_7_0-ibm security update for SLES 11 SP3 x86_64

Novell SUSE 2015:12251 java-1_7_0-ibm security update for SLES 11 SP3 i586

Novell SUSE 2015:12251 java-1_7_0-ibm security update for SLES 11 SP3 x86_64

Novell SUSE 2015:1538 java-1_6_0-ibm security update for SLES 11 SP3 i586

Novell SUSE 2015:1538 java-1_6_0-ibm security update for SLES 11 SP3 x86_64

VMSA-2015-0004 VMware Fusion 6.0.6 for Mac OS X (See Notes) (Rev 3)

VMSA-2016-0001 VMware Fusion 7.1.2 for Mac OS X (See Notes)


Last Updated: 27 May 2016 11:09:06