Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2015-1474

Overview

Vulnerability Score 10.0 10.0
CVE Id CVE-2015-1474
Last Modified 09 Apr 2015 10:00:24
Published 15 Feb 2015 07:59:06
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2015-1474

Summary

Multiple integer overflows in the GraphicBuffer::unflatten function in platform/frameworks/native/libs/ui/GraphicBuffer.cpp in Android through 5.0 allow attackers to gain privileges or cause a denial of service (memory corruption) via vectors that trigger a large number of (1) file descriptors or (2) integer values.

Vulnerable Systems

Operating System

  • Google Android 5.0


References

CONFIRM - https://android.googlesource.com/platform/frameworks/native/+/38803268570f90e97452cd9a30ac831661829091

BID - 72788

MISC - http://packetstormsecurity.com/files/130778/Google-Android-Integer-Oveflow-Heap-Corruption.html

SECTRACK - 1031875

FULLDISC - 20150311 [CVE-2015-1474]Integer overflow leading to heap corruption while unflattening GraphicBuffer


Last Updated: 27 May 2016 11:08:08